Page 1 of 2

Fullscreen in Windows 10

PostPosted: 11 Oct 2018, 11:24
by Dean
Hey Guys, I know there's a simple fix but I can't get Wolf to play in fullscreen in my Windows 10 laptop. I remember there was a way to fix it but i just can't remember how.

All games play perfectly, as well as through Dosbox but everything has the think (Several inches) of black bar around it. I've tried googling but can't find the fix.

Help me Obi-Wan Kenobi, you're my only hope! Thanks

Re: Fullscreen in Windows 10

PostPosted: 12 Oct 2018, 19:58
by AshenOne
Sounds like aspect ratio problem, open the dosbox config file and try to search for aspect it should have be under frameskip, set the aspect to true, it will do aspect correction. I hope this could help.

I also recommend to change the cpu core to dynamic and the cycles to max.

Re: Fullscreen in Windows 10

PostPosted: 15 Oct 2018, 01:51
by Dean
Thanks, I'll give that a try and see how I go :)

Re: Fullscreen in Windows 10

PostPosted: 17 Oct 2018, 11:32
by DoomJedi
I have now laptop with Windows 10 and Wolf3D works and displays fine.

I have to say - it's very uncomfortable to play games on laptop, but I'm new to this, maybe need to get used to it.

Re: Fullscreen in Windows 10

PostPosted: 18 Oct 2018, 10:54
by Dean
It plays fine but it's not full screen. I believe the resolution has to be a multiple of the original screen size for it to fit properly but none of those are an option for me.

Can anyone advise how to play in windowed mode instead?

Re: Fullscreen in Windows 10

PostPosted: 18 Oct 2018, 13:16
by AshenOne
Try to set the fullscreen to false in the doxbox config file, or try alt+enter, but I don't know it's still works on win10 os.

Re: Fullscreen in Windows 10

PostPosted: 23 Oct 2018, 04:36
by Tricob1974
The "--windowed" parameter is what's needed for the SDL ports. I'd do something like this:
Code: Select all
@Wolf4SDL --goobers --windowed --res 960 600

If this isn't set up right, it'll give you an error message.

Re: Fullscreen in Windows 10

PostPosted: 24 Oct 2018, 14:07
by Dean
Thanks Tricob, I'll give it a go, nothing has worked so far :(

Re: Fullscreen in Windows 10

PostPosted: 24 Oct 2018, 14:34
by Atina
Res for any 4:3 or 8:5 ratio. Resf for any other resolution like 16:9

--res 320 200
--resf 999 666
--windowed
--fullscreen

If you got black bars it's aspect ratio issue. Wolf4SDL doesn't have aspect ratio option so you can only adjust the resolution to your Windows 10 resolution.
You can also check your graphics driver options if your intel/nvidia/ati has "aspect ratio" option or "display scaling/stretching" which could fix it.

Re: Fullscreen in Windows 10

PostPosted: 25 Oct 2018, 12:12
by Dean
Thanks, I've checked the graphics driver and have added a new ratio but my AMD chip is stopping me from being able to adjust to the ratio.

I found a recorder with a screen selection tool so might just record and use the tool to chop off the surrounding black are.

Thanks for everyone's help